Merhaba. Ireport kullanarak main reportdan sub reporta nasil parameter gondere bilerim?Ireport 5.10 versiyonun kullaniyorum. Burda yazilanin aynisini denedim fakat sonuc vermedi,sub reportda olan yazilari gostermiyor : http://stackoverflow.com/a/14921393 Önceden teşekkürlər

alt text

alt text

Sonuc olaraq ise main repordaki verileri görüyorum: alt text

soruldu: 04 Kas '14, 02:04

Elxan's gravatar image

Elxan
135161924
cevap kabul oranı: 14%

değiştirildi: 04 Kas '14, 09:02


Bu yaptıklarınız doğru fakat ek olarak;

Subreportda Detail kısmına eklediğiniz $P{NAME} adlı parametreyi içeren TextField i Title, Page Header veya Column Header Band'larına taşımanız gerekiyor. Detail kısmında veritabanından dönen veya liste şeklide gelen aynı tip değişken verilerini gösterebilirsiniz.

Bunun dışında SubReport un propertisinde When No Data -> All selection, No Detail şekilde ayarlarsanız size detail kısmı boş gelmesine rağmen verileri gösterir. Aksi takdirde boş bir sayfa gösterir.

Ben şu an denedim verileri subreporta aktardı. Eğer sorun devam ederse resimleri de atarım.

Edit : Resimler. alt text

alt text

permanent link

cevaplandı: 05 Kas '14, 03:21

mikyas's gravatar image

mikyas
76113
cevap kabul oranı: 50%

değiştirildi: 05 Kas '14, 12:42

güncellenen reportu bana göndere bilirmisiniz?

(05 Kas '14, 09:02) Elxan Elxan's gravatar image

cok saol kardesim.Yalnisimi fark etdim.Benim subreportda "When Resource Missing Type" kismini Type Null secilmisdi.

(05 Kas '14, 14:36) Elxan Elxan's gravatar image

Merhaba,

Oluşturmuş olduğun main reportu açıp subreportu tıkladıktan sonra Properties penceresinden Parameter alanındaki "..." tıklayıp açılan pencereden Add deyip "Subreport Parameter Name" kısmına subreportunda bulunan parametre adını yazılacak Value Expression kısmında ise main reporttaki hangi parametre yi gönderecekseniz o parametreyi seçip Ok butonuna basıp kaydedilecek bu sayede main reporttaki parametreyi subreportta gönderebilirsiniz Umarım faydalı olur

permanent link

cevaplandı: 04 Kas '14, 06:58

kurtomerfaruk's gravatar image

kurtomerfaruk
1.3k222940
cevap kabul oranı: 30%

oyle yapdim zaten ,ama sub report-da olan verileri göstermiyor

(04 Kas '14, 08:25) Elxan Elxan's gravatar image

parametre isimlerinin eşleştiğini kontrol edin başka bir durum kalmıyor öyle tahmin ediyorum

(04 Kas '14, 08:49) kurtomerfaruk kurtomerfaruk's gravatar image

fotograflari yüklüyorum buraya

(04 Kas '14, 08:51) Elxan Elxan's gravatar image

soruyu güncelledim

(04 Kas '14, 10:33) Elxan Elxan's gravatar image

subreporttaki parametre adı doğru mu?

(04 Kas '14, 11:37) kurtomerfaruk kurtomerfaruk's gravatar image

Subreportdaki parametre adı main reportdaki parametre adı ile aynı

(04 Kas '14, 12:09) Elxan Elxan's gravatar image

herhangi bir datasource bağlantın olmadığından dolayı olabilir. datasource ekleyip dener misin subreportun Connection Type değerini "Use a connection expression" olarak seçip ve Connection Type ı ise "$P{REPORT_CONNECTION}" olarak ayarlayıp dener misin?

(04 Kas '14, 15:01) kurtomerfaruk kurtomerfaruk's gravatar image

Fotografdan dogru duzgun gorunmuyor ama ben de oyle yapdim.Burdan baka bilirsiniz :

https://www.dropbox.com/s/993mfi00jfn95i0/testreport.rar?dl=0

(05 Kas '14, 02:19) Elxan Elxan's gravatar image
8 yorumdan 5 tanesi gösteriliyor hepsini göster
Cevabınız
toggle preview

Bu soruyu takip et

E-Posta üzerinden:

Üyelik girişi yaptıktan sonra abonelik işlemlerini yapabilirsiniz

RSS üzerinden:

Cevaplar

Cevaplar ve Yorumlar

Yazı Formatlama

  • *italic* ya da _italic_
  • **bold** ya da __bold__
  • link:[text](http://url.com/ "başlık")
  • resim?![alt text](/path/img.jpg "başlık")
  • liste: 1. Foo 2. Bar
  • temel HTML etiketleri de kullanılabilir

Bu sorunun etiketleri:

×1,079
×8
×4

Soruldu: 04 Kas '14, 02:04

Görüntüleme: 597 kez

Son güncelleme: 05 Kas '14, 14:36

powered by BitNami OSQA