Deployment failed. The message was: weblogic.management.DeploymentException: com.sun.xml.ws.transport.http.servlet.WSServletException: WSSERVLET11: failed to parse runtime descriptor: java.lang.NullPointerException
The module has not been deployed.
See the server log for details.
    at org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy(Deployment.java:210)
    at org.netbeans.modules.maven.j2ee.ExecutionChecker.performDeploy(ExecutionChecker.java:178)
    at org.netbeans.modules.maven.j2ee.ExecutionChecker.executionResult(ExecutionChecker.java:130)
    at org.netbeans.modules.maven.execute.MavenCommandLineExecutor.run(MavenCommandLineExecutor.java:212)
    at org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:153)

Tomcat ile çalışan bir uygulamayı weblogic'e taşımaya çalışıyorum. webservisle alakalı bir problem var ama ona rağmen çözemedim sorunu fikri olan varmı ?

İyi Çalışmalar

soruldu: 13 Kas '14, 06:35

Mehmet%20KILIC's gravatar image

Mehmet KILIC
51191422
cevap kabul oranı: 20%

değiştirildi: 14 Kas '14, 02:40


WSSERVLET11: failed to parse runtime descriptor: java.lang.NullPointerException

Sorun XML konfigürasyon dosyasında. Bozuk /yanlış bir girdi yüzünden parse edilemiyor veya syntax hatası var.

permanent link

cevaplandı: 13 Kas '14, 08:32

Dkyc's gravatar image

Dkyc
1.6k1920
cevap kabul oranı: 29%

weblogic.xml dosyasınızı paylaşabilir misiniz? Yaptığınız tanımlamalarda bir problem görünüyor.

(13 Kas '14, 10:26) kurtomerfaruk kurtomerfaruk's gravatar image

weblogic.xml

  <?xml version="1.0" encoding="UTF-8"?>
<weblogic-web-app xmlns="http://xmlns.oracle.com/weblogic/weblogic-web-app" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd http://xmlns.oracle.com/weblogic/weblogic-web-app http://xmlns.oracle.com/weblogic/weblogic-web-app/1.0/weblogic-web-app.xsd">
  <jsp-descriptor>
    <keepgenerated>true</keepgenerated>
    <debug>true</debug>
  </jsp-descriptor>
  <context-root>/TestProject</context-root>
</weblogic-web-app>

belirttiğiniz dosya bu sun-jaxws.xml dosyasınıda atıyorum sanki problem orada ...

sun-jaxws.xml

<?xml version="1.0" encoding="UTF-8"?>
<endpoints version="2.0" xmlns="http://java.sun.com/xml/ns/jax-ws/ri/runtime">
    <endpoint implementation="com.yaz.yazproject.uni.services.EUniServices"    url-pattern="/EUniServices"/>
    <endpoint implementation="com.yaz.yazproject.okul.services.EOkulServices"  url-pattern="/EOkulServices"/>
    <endpoint implementation="com.yaz.yazproject.library.services.ELibraryService"  url-pattern="/ELibraryService"/>

</endpoints>
permanent link

cevaplandı: 14 Kas '14, 01:24

Mehmet%20KILIC's gravatar image

Mehmet KILIC
51191422
cevap kabul oranı: 20%

değiştirildi: 14 Kas '14, 02:39

weblogic loglarını kontrol edebilir misiniz? Hatayı nerede veriyorsunuz bu tür durumlarda sizin kullanmış olduğunuz jarları değilde kendi içindeki jarları kullanmaya çalışıyor bu sayede uyuşmazlık oluşuyor ve hataya düşüyor bu tür durumlarda weblogic.xml dosyasında tanımlama yapmanız gerekiyor.

(14 Kas '14, 08:32) kurtomerfaruk kurtomerfaruk's gravatar image
Cevabınız
toggle preview

Bu soruyu takip et

E-Posta üzerinden:

Üyelik girişi yaptıktan sonra abonelik işlemlerini yapabilirsiniz

RSS üzerinden:

Cevaplar

Cevaplar ve Yorumlar

Yazı Formatlama

  • *italic* ya da _italic_
  • **bold** ya da __bold__
  • link:[text](http://url.com/ "başlık")
  • resim?![alt text](/path/img.jpg "başlık")
  • liste: 1. Foo 2. Bar
  • temel HTML etiketleri de kullanılabilir

Bu sorunun etiketleri:

×21
×6
×1

Soruldu: 13 Kas '14, 06:35

Görüntüleme: 782 kez

Son güncelleme: 14 Kas '14, 08:32

powered by BitNami OSQA