Merhaba Normal projede build edince jar dosyası oluşuyor ve sorunsuz çalışıyor. maven projesinde build ediyorum ama oluşan jar çalışmıyor araştırma yaptım biraz

java -jar AnaProgram.jar

alt text kodunu kullandım ama "no main manifest attributei in AnaProgram.jar" gibi bi hata verdi biraz daha araştırdım. pom.xml dosyasına şunları eklemem gerektiği yazıyor.

<build>
    <plugins>
        <plugin>
          <groupId>org.apache.maven.plugins</groupId>
          <artifactId>maven-assembly-plugin</artifactId>
          <configuration>
            <archive>
                <manifest>
                    <mainClass>com.hmo.MainFrame</mainClass>
                </manifest>
            </archive>
            <descriptorRefs>
                <descriptorRef>jar-with-dependencies</descriptorRef>
            </descriptorRefs>
          </configuration>
        </plugin>
    </plugins>
</build>

ekledim sorun yine aynı sorun çözemedim bi türlü

günlerdir bu projeyle uğraşıyorum proje bitti ama çalışır bi jar alamıyorum yardımcı olursanız çok sevinirim.

alt text alt text

soruldu: 31 Ara '15, 07:19

ahmethmo's gravatar image

ahmethmo
120101521
cevap kabul oranı: 50%

değiştirildi: 05 Oca, 03:45


pom.xml'inin tamını paylaşabilir misin?

permanent link

cevaplandı: 04 Oca, 04:55

mehmetunluu's gravatar image

mehmetunluu
100114
cevap kabul oranı: 0%

pom.xml in üst kısmınıda ekledim

(05 Oca, 03:46) ahmethmo ahmethmo's gravatar image
Cevabınız
toggle preview

Bu soruyu takip et

E-Posta üzerinden:

Üyelik girişi yaptıktan sonra abonelik işlemlerini yapabilirsiniz

RSS üzerinden:

Cevaplar

Cevaplar ve Yorumlar

Yazı Formatlama

  • *italic* ya da _italic_
  • **bold** ya da __bold__
  • link:[text](http://url.com/ "başlık")
  • resim?![alt text](/path/img.jpg "başlık")
  • liste: 1. Foo 2. Bar
  • temel HTML etiketleri de kullanılabilir

Bu sorunun etiketleri:

×1,076
×29
×16

Soruldu: 31 Ara '15, 07:19

Görüntüleme: 343 kez

Son güncelleme: 05 Oca, 03:46

powered by BitNami OSQA