Python da Yeni sayfa açtıüımda ufak bir kod parçasını dahi derlemeye çalışsam : http://b1210.hizliresim.com/12/r/f726m.png

hatayı alıyorum sanırım kod standartlarının uymamasından dolayı derleyemiyor yeterli seviyede ingilizcemde olmadığı için elimden pek bişey gelmıyor . Çözümü yazana Şimdiden Teşekkürler.

soruldu: 23 Eki '12, 13:13

aspawa's gravatar image

aspawa
-1335
cevap kabul oranı: 0%

değiştirildi: 24 Eki '12, 01:11

%C3%B6zcanacar's gravatar image

özcanacar ♦♦
17.2k59183183


Standart python kodlarını sorunsuz çalıştırabiliyor musunuz?

import os
print os.environ["USERNAME"]

vs. gibi. Ayrıca şuradaki başka yazılım geliştirme araçlarından birisiyle de test edebilirsiniz:
http://www.btsoru.com/questions/120/python-yazlm-icin-hangi-ideyi-kullanyorsunuz

permanent link

cevaplandı: 23 Eki '12, 14:15

rahmanyazgan's gravatar image

rahmanyazgan ♦
4.4k83559
cevap kabul oranı: 26%

değiştirildi: 23 Eki '12, 14:40

verdiğiniz kod parçası çalışmadı. şimdi eclipse + pydev i deniyorum

(23 Eki '12, 15:06) aspawa aspawa's gravatar image

Hangi python sürümünü kurdunuz. Kod python 3.x serisinde çalışmayacaktır.
Python 3.x serisi kuruluysa aşağıdaki kod parçacığını test edin:
print("Test")

(23 Eki '12, 15:29) rahmanyazgan ♦ rahmanyazgan's gravatar image

bu kod IDLE'nin Shellinde çalışıyor(Diğer kodlarda Shellde çalışıyordu sorunum Yeni pencere açınca gelen ekranda idi) Ctrl+N yapıp Run dediğim zaman yine aynı hatayı aldım ama verdiğiniz siteden eclipse + Pydev i kurdum çalıştı şimdii onu test ediyorum baakalım arıza çıkacakmı ondada

(23 Eki '12, 16:35) aspawa aspawa's gravatar image

Windows 7 64 bit sisteme 64 bit Python 3.3 sürümünü kurup bahsettiğiniz sorunlara baktım, bir sorun görünmüyor, sorunsuz çalışıyor.

Belki güncellemelerle alakalı bir sorundur. Sisteminizin güncellemesi varsa yapın isterseniz ve kurulu Python sürümünü kaldırıp tekrar da kurabilirsiniz.

(23 Eki '12, 16:44) rahmanyazgan ♦ rahmanyazgan's gravatar image

Python sürümünü de değiştirebilirsiniz. 2.7 yi deneyiniz.

(24 Eki '12, 06:04) electrocoder electrocoder's gravatar image

sürüm ü 3 ten aşağı düşürdüğüm zaman kodlarda değişiklik olabiliyor bende yeni öğrenmeye başladığım için şuanda sıkıntılı olur. Şimdi eksik güncellemeleri tamamlıorum

(25 Eki '12, 14:22) aspawa aspawa's gravatar image
6 yorumdan 5 tanesi gösteriliyor hepsini göster
Cevabınız
toggle preview

Bu soruyu takip et

E-Posta üzerinden:

Üyelik girişi yaptıktan sonra abonelik işlemlerini yapabilirsiniz

RSS üzerinden:

Cevaplar

Cevaplar ve Yorumlar

Yazı Formatlama

  • *italic* ya da _italic_
  • **bold** ya da __bold__
  • link:[text](http://url.com/ "başlık")
  • resim?![alt text](/path/img.jpg "başlık")
  • liste: 1. Foo 2. Bar
  • temel HTML etiketleri de kullanılabilir

Bu sorunun etiketleri:

×41

Soruldu: 23 Eki '12, 13:13

Görüntüleme: 961 kez

Son güncelleme: 25 Eki '12, 14:22

powered by BitNami OSQA