Merhabalar JSP ile uğraşıyorum ve server olarak Tomcat i kullanıyorum.Proje yaparken tomcati oluşturup projemi çalıştırıyorum hiç bir sorun yok her şekilde servlet işlemleri çalışıyor fakat bilgisayarı açıp kapattığımıda tekrar projelerimi çalıştırdığımda index.jsp de 404 hatası alıyorum bunun onune geçemedim.Bunun nedeni sizce nedir ? Teşekkürler

soruldu: 09 Şub '13, 16:46

keramiozsoy's gravatar image

keramiozsoy
171131519
cevap kabul oranı: 50%

değiştirildi: 01 Tem '13, 23:23

%C3%B6zcanacar's gravatar image

özcanacar ♦♦
17.2k59183183

Projen doğru deploy edilmiyordur. Clean deyip başlatabilir misin? Bir de başlığı soru şeklinde sormalısın.

(09 Şub '13, 16:49) Tunahan Pehlivan Tunahan%20Pehlivan's gravatar image

server clean work yaptım bu seferde servlet sınıflarının hiçbiri çalışmamaya başladı

(09 Şub '13, 16:58) keramiozsoy keramiozsoy's gravatar image

Tomcat'in bazı dağıtımları problemli. 7.0.27 dağıtımıda 2 saatte bir isteklere cevap vermez hale geliyordu fakat kendisi hala çalışıyordu. Araştırdım bazen bu tür bir bug oluşabiliyormuş, öğrendim ve 7.0.35 dağıtımı ile değiştirdim. Şuan sunucumun üzerinde 8 uygulama var ve oldukça stabil çalışıyor. Tomcat'i kaldırıp farklı bir dağıtımında deneyin. (Dağıtımı, Versiyon olarak kullandım)

(09 Şub '13, 17:14) Turgay Can Turgay%20Can's gravatar image

Suncularla ilgili bende de glassfish 3.1 sunucu tarafındaki değişikliği algılayıp otomatik deploy etmeye çalıştığında bazen %33 de kalıyor ve bilgisayarı yeniden başlatmam gerekiyor. Bununla ilgili bir önerin var mı?

(10 Şub '13, 03:44) Tunahan Pehlivan Tunahan%20Pehlivan's gravatar image

Sürümü bende yükselteyim dedim 3.1'den 3.1.2'ye hiç bir sorun kalmadı :)

(10 Şub '13, 14:31) Tunahan Pehlivan Tunahan%20Pehlivan's gravatar image

Tunahan aynı sorunu bende yaşıyordum 2 gün öncesine kadar, 3.1.2 ile problem kalmadı bendede.

(10 Şub '13, 16:49) Turgay Can Turgay%20Can's gravatar image
6 yorumdan 5 tanesi gösteriliyor hepsini göster

Tomcat eğer exe olarak dışardan kurulmuş ise otomatik çalıştırmasını durdurdum.Diğer taraftan iki kere aynı tomcatı çalıştırdığı için hata verdiği kanaatine vardım.Sorunum çözüldü.

permanent link

cevaplandı: 16 Haz '13, 08:50

keramiozsoy's gravatar image

keramiozsoy
171131519
cevap kabul oranı: 50%

Cevabınız
toggle preview

Bu soruyu takip et

E-Posta üzerinden:

Üyelik girişi yaptıktan sonra abonelik işlemlerini yapabilirsiniz

RSS üzerinden:

Cevaplar

Cevaplar ve Yorumlar

Yazı Formatlama

  • *italic* ya da _italic_
  • **bold** ya da __bold__
  • link:[text](http://url.com/ "başlık")
  • resim?![alt text](/path/img.jpg "başlık")
  • liste: 1. Foo 2. Bar
  • temel HTML etiketleri de kullanılabilir

Bu sorunun etiketleri:

×111
×47

Soruldu: 09 Şub '13, 16:46

Görüntüleme: 995 kez

Son güncelleme: 01 Tem '13, 23:23

powered by BitNami OSQA