Merhaba arkadaşlar, index.jsp sayfamda bir input' tan değer alırken (ş,i,ğ,ü,ö,ç) gibi karakterleri girildiğinde Ç,ü gibi çıktılar veriyor. <%@page contentType="text/html; charset=UTF-8"%> gibi şeyler jsp sayfamda var. Bu sorunu nasıl düzeltebilirim?

soruldu: 06 Eyl '13, 05:23

ufukhalis's gravatar image

ufukhalis
121131820
cevap kabul oranı: 54%

değiştirildi: 06 Eyl '13, 09:36

%C3%B6zcanacar's gravatar image

özcanacar ♦♦
17.2k59183183

Sadece bir tahmin! Kullandığın editörde, .jsp sayfanı "UTF-8 No Boom" olarak kaydetmeyi dene. Bazen sunucular kaynak dosyanın formatının farklı olmasından ötürü problem çıkarabiliyor.

(07 Eyl '13, 05:50) Oğuz Çelikdemir O%C4%9Fuz%20%C3%87elikdemir's gravatar image

Arkadaşlar çok ilginç bir şekilde sorunum çözüldü. Projeyi çalıştırdığımda http://localhost:8085/WebCrawling/ şeklinde geliyordu. sonra form'u submit ettiğimde out.println ile değerimi çıktısını yazdırıyordum. Çıkan şekil yukarıda belirttiğim gibi bozuk karakterler çıkıyordu. http://localhost:8085/WebCrawling/index.jsp olarak değiştirdiğimde ise çıktının düzeldiğini gördüm. Şimdi ise projeyi her çalıştırdığımda http://localhost:8085/WebCrawling/index.jsp olarak gelmesini nasıl sağlarım çünkü hep http://localhost:8085/WebCrawling/ şeklinde geliyorç

permanent link

cevaplandı: 09 Eyl '13, 02:48

ufukhalis's gravatar image

ufukhalis
121131820
cevap kabul oranı: 54%

Kod tam çıkmadı ama html yönlendirme diye aratırsın.. <meta http-equiv="Refresh" content="0; url=" index.jsp"=""/>

(09 Eyl '13, 02:53) Erdemym Erdemym's gravatar image

request.setCharacterEncoding("UTF-8"); denermisin servlet sınıfında , başka bir yolu daha vardı ama şimdi hatırlayamadım musait olunca bakarım.

permanent link

cevaplandı: 06 Eyl '13, 05:47

jackk's gravatar image

jackk
5422417
cevap kabul oranı: 4%

Servlet sınıfı olmadan yazılması isteniyor. O yüzden bir servlet sınıfım yok. input içindeki değerleri jsp sayfasındayken alıyorum ve kullanacağım sınıfa set ediyorum.

(06 Eyl '13, 05:53) ufukhalis ufukhalis's gravatar image

controller olarak ne tür bi yapı kullanıyosun.

(06 Eyl '13, 05:55) jackk jackk's gravatar image

jsp sayfasınının en basınada <% request.setCharacterEncoding("UTF-8"); response.setCharacterEncoding("UTF-8"); %> ekleyebilirsin.

(06 Eyl '13, 06:15) jackk jackk's gravatar image

request.setCharacterEncoding("UTF-8"); response.setCharacterEncoding("UTF-8"); jsp sayfama koydum fakat aynı sonuç..

(06 Eyl '13, 07:09) ufukhalis ufukhalis's gravatar image

Filter sınıfı ile Servlet tabanında çözümü : -> Kaynak

Ek olarak; Benimde bu tür bir sorunum olmuştu tomcat web sunucusunda çözüm olarak, caalina.sh / catalina.batch dosyası içine

set CATALINA_OPTS=-Dfile.encoding="UTF-8"

parametresini eklemiştim yeterli olmuştu.

GlassFish app server'ı kullanıyorsanda glassfish-web.xml içine aşağıdaki parametreyi eklemen yeterli olur.

<parameter-encoding default-charset=”UTF-8″/>
permanent link

cevaplandı: 06 Eyl '13, 06:19

Turgay%20Can's gravatar image

Turgay Can
8.3k63798
cevap kabul oranı: 18%

değiştirildi: 07 Eyl '13, 05:42

Çözümünü denedikten sonra mesaj atacağım teşekkürler...

(06 Eyl '13, 07:10) ufukhalis ufukhalis's gravatar image

bu söylediğin dosyalar içinde çokça yazı var neresine yapıştırdığım önemli mi?

(06 Eyl '13, 07:18) ufukhalis ufukhalis's gravatar image

Tomcat mi, GlassFish mi kullanıyorsun yada farklı bir sunucumu kullanıyorsun? Tomcat için diyorsan catalina içinde set java_opts altıan yerleştirebilirsin.

set CATALINA_OPTS=-Dfile.encoding="UTF-8"

yada Server.xml içinde Connector tag içine parametre olarak ;

URIEncoding="UTF-8" ekleyebilirsin.

Connector port="8080" protocol="HTTP/1.1" connectionTimeout="20000" redirectPort="8443" URIEncoding="UTF-8"/>

(06 Eyl '13, 07:37) Turgay Can Turgay%20Can's gravatar image

Tomcat 7.x kullanıyorum Dediklerini ekledim tomcat çalışmıyor.

(06 Eyl '13, 07:47) ufukhalis ufukhalis's gravatar image

söylediklerimin hepsini eklemeyiniz. Eğer işletim sisteminiz windows ise catalina.bat dosyası içine SET JAVA_OPTS parametresi altına ;

set CATALINA_OPTS=-Dfile.encoding="UTF-8" ekleyiniz.

Linux ise aynı işlemi catalina.sh dosyası içinde yapınız.

Tomcat'e parametre tanımlamak ile down olmaz.

(06 Eyl '13, 07:49) Turgay Can Turgay%20Can's gravatar image

windows kullanıyorum. Şimdi set java_opts adında iki parametre var farklı yerlerinde

if not "%LOGGING_CONFIG%" == "" goto noJuliConfig set LOGGING_CONFIG=-Dnop if not exist "%CATALINA_BASE%\conf\logging.properties" goto noJuliConfig set LOGGING_CONFIG=-Djava.util.logging.config.file="%CATALINA_BASE%\conf\logging.properties" :noJuliConfig set JAVA_OPTS=%JAVA_OPTS% %LOGGING_CONFIG%

if not "%LOGGING_MANAGER%" == "" goto noJuliManager set LOGGING_MANAGER=-Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager :noJuliManager set JAVA_OPTS=%JAVA_OPTS% %LOGGING_MANAGER%

gibi

(06 Eyl '13, 08:07) ufukhalis ufukhalis's gravatar image

Bri satır boşluk bırakıp, bunların altına tanımlayınız.

(06 Eyl '13, 08:13) Turgay Can Turgay%20Can's gravatar image

Geç cevap verdiğim için kusura bakmayınız, Boşluk bırakıp altına tanımladığımda da değişen bir durum olmadı. Netbeans ortamında tomcat 7.x sürümünü kulllanarak windows' da yapıyorum projemi. Hala çözemedim.

(09 Eyl '13, 01:03) ufukhalis ufukhalis's gravatar image
8 yorumdan 5 tanesi gösteriliyor hepsini göster
Cevabınız
toggle preview

Bu soruyu takip et

E-Posta üzerinden:

Üyelik girişi yaptıktan sonra abonelik işlemlerini yapabilirsiniz

RSS üzerinden:

Cevaplar

Cevaplar ve Yorumlar

Yazı Formatlama

  • *italic* ya da _italic_
  • **bold** ya da __bold__
  • link:[text](http://url.com/ "başlık")
  • resim?![alt text](/path/img.jpg "başlık")
  • liste: 1. Foo 2. Bar
  • temel HTML etiketleri de kullanılabilir

Bu sorunun etiketleri:

×1,077
×111
×5

Soruldu: 06 Eyl '13, 05:23

Görüntüleme: 2,121 kez

Son güncelleme: 09 Eyl '13, 02:57

powered by BitNami OSQA